École Privée d’Ingénierie du Niger — L’école du nouveau monde

✉ elearning@epiniger.edu.ne    🌐 epiniger.edu.ne

Écrit par

dans

Master Professionnel en Cybersécurité et Cybercriminalité (MCS) › Master 1 › Master MCS · S1 · UE3 — Réseaux et sécurité

Protocoles sécurisés

Code PSE4132 5 crédits CM 30h · TD 20h · TP 0h · TPE 50h Évaluation : CC + ET

👤 Pr MAHAMADOU ISSOUFOU TIADO — Professeur CAMES en Réseaux et Télécommunications

Se connecter pour s'inscrire Créer un compte

4 leçon(s) · 1 quiz · 0 inscrit(s)

Présentation

Ce cours approfondit les protocoles qui protègent les communications réseau : il s’appuie sur les acquis des cours de cryptographie et d’architecture des réseaux. Après les enjeux et principes communs (modèle d’adversaire, propriétés attendues, poignée de main, dérivation de clés, anti-rejeu, choix de la couche de protection), il étudie en détail TLS 1.2 et 1.3 et la configuration d’un serveur HTTPS, IPsec (ESP, IKEv2, surcoût et anti-rejeu) et les VPN site à site et d’accès distant (IPsec, VPN TLS, WireGuard), puis SSH et l’administration sécurisée, avant d’analyser les grandes familles de vulnérabilités des protocoles et la méthode d’évaluation de leur configuration. Les travaux dirigés comprennent des calculs (latence, surcoûts, fenêtres anti-rejeu) et des exercices guidés réalisés exclusivement dans le laboratoire de l’étudiant ou sur des systèmes pour lesquels une autorisation écrite existe, conformément à la loi sur la cybercriminalité.

Objectifs d’apprentissage

  • Expliquer les enjeux de la sécurisation des protocoles et les propriétés à garantir.
  • Décrire le fonctionnement de TLS, IPsec/IKEv2 et SSH.
  • Configurer des protocoles sécurisés (HTTPS, VPN IPsec, SSH) selon l’état de l’art.
  • Dimensionner un tunnel (MTU, MSS, renouvellement des clés) et en évaluer les performances.
  • Évaluer la sécurité des protocoles déployés et identifier leurs vulnérabilités potentielles.

Prérequis

Réseaux informatiques (modèles OSI/TCP-IP, adressage, TCP/UDP) et cryptographie (chiffrement symétrique et asymétrique, hachage, certificats), administration Linux de base.

Plan du cours

  1. Leçon 1 — Enjeux et principes des protocoles sécurisés
  2. Leçon 2 — SSL/TLS : sécuriser les communications web
  3. Leçon 3 — IPsec et réseaux privés virtuels (VPN)
  4. Leçon 4 — SSH et analyse des vulnérabilités des protocoles sécurisés

Modalités d’évaluation

Volume horaire : 30 h de cours magistral, 20 h de travaux dirigés (calculs, revues de configurations, exercices guidés HTTPS, VPN et SSH en laboratoire), 50 h de travail personnel ; 5 crédits. Évaluation : contrôle continu (TD, quiz, compte rendu de laboratoire « avant/après durcissement ») pour 40 % et examen terminal écrit pour 60 %.

Bibliographie

  • Rescorla, E., SSL and TLS: Designing and Building Secure Systems, Addison-Wesley, 2001.
  • Kaufman, C., Perlman, R. et Speciner, M., Network Security: Private Communication in a Public World, 2e éd., Prentice Hall, 2002.
  • Ristić, I., Bulletproof TLS and PKI, Feisty Duck.
  • Barrett, D. J., Silverman, R. E. et Byrnes, R. G., SSH, The Secure Shell: The Definitive Guide, O’Reilly.
  • IETF, RFC 8446 (TLS 1.3), RFC 7296 (IKEv2), RFC 4303 (ESP), RFC 4251 à 4254 (SSH) ; NIST SP 800-52 Rev. 2 et SP 800-77 Rev. 1.

Évaluation globale de la matière

Connectez-vous pour suivre votre progression.

Programme

  1. 🔒 Leçon 1 — Enjeux et principes des protocoles sécurisés · 90 min
  2. 🔒 Leçon 2 — SSL/TLS : sécuriser les communications web · 90 min
  3. 🔒 Leçon 3 — IPsec et réseaux privés virtuels (VPN) · 90 min
  4. 🔒 Leçon 4 — SSH et analyse des vulnérabilités des protocoles sécurisés · 90 min
  5. 🔒 Quiz — Protocoles sécurisés · quiz

Évaluation globale de la matière

Connectez-vous pour suivre votre progression.